Configuration d'un Switch Catalyst

From Deimos.fr / Bloc Notes Informatique
Jump to: navigation, search
Flattr-badge-large.png

1 Branchements

On commence par brancher le port série côté PC et le port console sur le commutateur.

2 Connection

On lance l'hperterminal et on choisi une connection sur le port com1, ou un autre com selon la configuration du pc. Il faut choisir 9600Bauds le reste importe peu...

3 Ce qu'il faut savoir

au lancement du terminal on va déterminer plusieurs choses :

  • le nom du routeur (par exemple : swpar5)
  • un secret
  • un password
  • un virtual terminal password

Ensuite il faut passer en mode "enable" pour pouvoir changer la configuration

enable

le prompt passe de swpar5> à swpar5#

Dans ce mode on peut consulter la configuration du routeur en tapant

sh run

4 Ressources

Notions de base Cisco si on veut modifier cette configuration il faut passer en mode "conf"

conf t

résultat : le prompt passe en swpar5(config)#

le "t" est pour désigner que l'on désire configurer le routeur en mode terminal.

4.1 Configuration de l'adresse ip d'une interface

en effectuant un sh run on peut voir les différentes interfaces, comme ceci:

interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address 
 no ip route-cache
!
ip http server
!
control-plane
!
!
line con 0
line vty 0 4
 password *xxxxx*
 no login
line vty 5 15

On voit ici une interface nommée Vlan1 qui n'as pas d'adresse ip, et on remarque que les deux lignes qui suivent sont décalées par un espace, on peut donc les modifier en tapant, en mode "configuration":

interface Vlan1

le prompt passe alors en swpar5(config-if)# Puis on tape

ip address 192.168.0.169 255.255.255

puis retourner en mode enable (avec le prompt swpar5#) et taper:

wr m

pour sauvegarder

A partir de là on peut accéder a l'interface web du routeur en tapant

http://192.168.0.169

4.2 Mise à jour du firmware

4.2.1 Connaitre la version du firmware

On tape

sh ver

4.2.2 Télécharger la dernière version

Aller sur cisco.fr-->support-->download software-->software advisor-->Find software compatible with my hardware-->Select your hardware configuration manually-->puis choisir le modèle du routeur et télécharger l'archive. On a le choix entre un logiciel qui supporte le CRYPTO (connexion securisée https) ou qui ne le fait pas.

4.2.3 Installer le nouveau firmware

Il s'agit d'une archive .tar qu'il faut charger depuis l'interface web du routeur, tout ets automatique.

4.3 Configuration du dommaine vtp

swpar5(config)#vtp mode client     (ou server ou transparent)
swpar5(config)#vtp domain ulnet-fr 

http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/12.1/12ew/configuration/guide/vtp.html#wp1032093

4.4 Configuration d'une interface

Passage en mode trunk permet de faire passer plusieurs Vlan sur un seul ports entre plusieurs switch :

swpar5(config-if)#switchport mode trunk
swpar5(config-if)#switchport nonegotiate
swpar5(config-if)#auto qos voip trust 
swpar5(config-if)#macro description cisco-switch
swpar5(config-if)#spanning-tree link-type point-to-point

4.5 Créer une Vlan

se mettre en mode configuration, et taper

swpar5(config)#vlan x

où "x" est un "id" pour le vlan (un numéro), puis choisir un nom pour cette Vlan, pour cela, en mode conf, taper "vlan x"

swpar5(config-vlan)#name le_nom_de_la_vlan

On peut vérifier la configuration des Vlan avec la commande

swpar5#sh vlan

Une fois la Vlan créer il est mieux de la mettre en "no-shtudown" pour qu'elle ne se désactive pas automatiquement:

swpar5(config-if)#noshutdown

http://www.cisco.com/en/US/docs/switches/lan/catalyst2960/software/release/12.2_25_fx/configuration/guide/swvlan.html#wp1273595

4.5.1 Assigner une interface à une Vlan

On rentre en mode configuration et on choisi une interface, par exemple "interface FastEthernet0/1", et on tape

swpar5(config-if)#switchport mode access
swpar5(config-if)#switchport access vlan 3 (si le vlan s'appelle "vlan 3")

4.6 Mode Graphique

Une fois que l'on a assigné une adresse IP on peut accéder via http a l'interface graphique du switch, lorsque l'on nous demande un nom d'utilisateur de un mdp, il faut mettre seulement le mdp que l'on a seter au début.

5 Resources

Notions de base Cisco